logilab-database #83174 [packaging] incompatible with python2.4 [done]

On upgrade on a debian system than needs a python2.4 on the side, I get

Compiling /usr/lib/pymodules/python2.4/logilab/database/__init__.py ...
File "/usr/lib/pymodules/python2.4/logilab/database/__init__.py", line 330
  transform = lambda v: unicode(v, encoding, 'replace') if isinstance(v, str) else v
                                                         ^
SyntaxError: invalid syntax

Compiling /usr/lib/pymodules/python2.4/logilab/database/sqlserver.py ...
File "/usr/lib/pymodules/python2.4/logilab/database/sqlserver.py", line 184
  transform = lambda v: unicode(value, encoding, 'replace') if isinstance(v, str) else v
                                                             ^
SyntaxError: invalid syntax

Saving new apt-history status...

I don't mind if logilab-database is not installed in python2.4...

prioritynormal
typebug
done in<not specified>
load left0.000
closed by<not specified>