yams #59211 SyntaxError on python-support for another python package [done]

While installing another python package, I get the following warning for yams

Processing triggers for python-support ...
Compiling /usr/lib/pymodules/python2.4/yams/tools.py ...
  File "/usr/lib/pymodules/python2.4/yams/tools.py", line 84
    class MockConfig():
                      ^
SyntaxError: invalid syntax

Version : 0.30.3-1 on a lenny machine

prioritynormal
typebug
done in0.36.0
load left0.000
closed by<not specified>