logilab-database #266917 add support for pyodbc > 2 (>= 3) [validation pending]

It is currently not supported at least in the sense that bytearrays won't be converted in Binaries.

prioritynormal
typeenhancement
done in1.13.2
load0.500
load left0.000
closed by#c375a800ff36 [sqlserver] work around pyodbc bug (closes #266917)
patch[sqlserver] work around pyodbc bug (closes #266917) [rejected][sqlserver] work around pyodbc bug (closes #266917) [applied]