logilab-common #265740 make source py3k-compatible without 2to3 [validation pending]

targetting at least 3.3, because not having u'foo' string literals makes 3.2 too painful.

prioritynormal
typeenhancement
done in0.63.0
load5.000
load left0.000
closed by#9332c143b37c [pkg] don't run 2to3 in setup.py
patch[pkg] don't run 2to3 in setup.py [applied][py3k] explicitly build a list around dict methods [applied]