logilab-common #258060 use of class decorator in shellutils breaks py2.5 compat [validation pending]

still needed by pylint for now

prioritynormal
typebug
done in0.62.1
load left0.000
closed by#6f1ad7bfec97 [shellutils] don't use class decorator, we still need py 2.5 compat for some time. Closes #258060
patch[shellutils] don't use class decorator, we still need py 2.5 compat for some time. Closes #258060 [applied]