nazca #252733 Add compatibility for older version of sklearn [validation pending]

For clustering (n_cluster != k)

prioritynormal
typebug
done in0.6.0
load0.100
load left0.000
closed by#56114a122a56 [blocking] Add compatibility for older version of sklearn, closes #252733
patch[blocking] Add compatibility for older version of sklearn, closes #252733 [applied]