logilab-database #235432 remove support for deprecated postgresql backends [validation pending]

and keep only psycopg2

prioritynormal
typetask
done in1.13.0
load0.500
load left0.000
closed by#0a8db937ad7b [postgres] remove support for non-psycopg2 drivers
patch[postgres] remove support for non-psycopg2 drivers [applied]