logilab-devtools #228339 missing python-rpm shouldn't be an error [resolved]

Error while running checker lgp.build: rpm unsupported: missing rpm python module
Traceback (most recent call last):
File "/usr/lib/python2.6/dist-packages/apycotlib/atest.py", line 295, in run_checker
status = checker.check(self)
File "/usr/lib/python2.6/dist-packages/apycotlib/checkers/__init__.py", line 27, in check
self.set_status(self.do_check(test))
File "/var/lib/narval/plugins/lgp.py", line 110, in do_check
exit_status = cmd.main_run(args, LGP.rcfile)
File "/usr/lib/pymodules/python2.6/logilab/devtools/lgp/setupinfo.py", line 196, in main_run
self.run(arguments)
File "/usr/lib/pymodules/python2.6/logilab/devtools/lgp/build.py", line 180, in run
self.make_orig_tarball(tmpdir)
File "/usr/lib/pymodules/python2.6/logilab/devtools/lgp/build.py", line 242, in make_orig_tarball
self._check_rpm_version_mismatch(specfile)
File "/usr/lib/pymodules/python2.6/logilab/devtools/lgp/setupinfo.py", line 394, in _check_rpm_version_mismatch
rpm_upstream_version = utils.parse_rpm_version(specfile)
File "/usr/lib/pymodules/python2.6/logilab/devtools/lgp/utils.py", line 243, in parse_rpm_version
raise LGPException('rpm unsupported: missing rpm python module')
LGPException: rpm unsupported: missing rpm python module

this should be a warning imo.

prioritynormal
typebug
done in0.22.2
load0.100
load left0.000
closed by#38e4c77fc54c Backout 4e611b5e2508 "Do a 3-way version check (upstream, debian, specfile)"