logilab-common #140667 [configuration] rename option_name to option_attrname [validation pending]

Since OptionsProviderMixIn.option_name() returns the name of the attribute of the config object, it would be better to name it option_attrname().

prioritynormal
typeenhancement
done in0.60.0
load0.200
load left0.000
closed by#094a4f101403 [configuration] rename option_name to option_attrname (closes #140667)
patch[configuration] rename option_name to option_attrname (closes #140667) [applied]