rql #10147668 upgrade libgecode from 4.4.0 to 6.x [open]

rql is currently depending on libgecode 4.4.0. it would be nice to upgrade to a more recent version. See https://github.com/Gecode/gecode/releases

priorityimportant
typeenhancement
done in<not specified>
closed by<not specified>