logilab-common #10132697 refactor or remove logilab.common.compat [open]

In 2019 there are better ways to have code compatible with several python versions than to use logilab.common.compat.

We should either deprecate it completely or make it an empty shell with deprecation warnings and recommend using six for example.

prioritynormal
typeenhancement
done in<not specified>
closed by<not specified>