hgview #10126859 hgview fails on SCons repository [done]

I am finding that I cannot use hgview on Debian Sid. I had been using the Debian package, but have now tried hgview using the Mercurial repository and have the same error. I have reported the big on the Debian system (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=872692), but it seems right to report it here now that it is clear that the problem is in the hgview master repository.

If I run hgview not in a Mercurial repository directory I get the file chooser dialogue. If I navigate to a repository or start hgview in a Mercurial repository directory, I get:

Traceback (most recent call last):
File "/home/users/russel/bin/hgview", line 38, in <module>
main()
File "/home/Checkouts/Mercurial/HgView/hgviewlib/application.py", line 226, in main
sys.exit(start(repo, opts, args, parser.error))
File "/home/Checkouts/Mercurial/HgView/hgviewlib/application.py", line 174, in start
app = Application(repo, opts, args)
File "/home/Checkouts/Mercurial/HgView/hgviewlib/qt4/application.py", line 54, in __init__
super(HgViewQtApplication, self).__init__(*args, **kwargs)
File "/home/Checkouts/Mercurial/HgView/hgviewlib/application.py", line 84, in __init__
self.choose_viewer()
File "/home/Checkouts/Mercurial/HgView/hgviewlib/application.py", line 108, in choose_viewer
viewer = self.HgRepoViewer(self.repo)
File "/home/Checkouts/Mercurial/HgView/hgviewlib/qt4/hgrepoviewer.py", line 106, in __init__
self._repodate = self._getrepomtime()
File "/home/Checkouts/Mercurial/HgView/hgviewlib/qt4/hgrepoviewer.py", line 623, in _getrepomtime
for l in (self.repo.sjoin('lock'), self.repo.join('wlock')):
AttributeError: 'localrepository' object has no attribute 'join'

priorityimportant
typebug
done in<not specified>
load left0.000
closed by#bc780e7d305c Use repo.vfs.join instead of repo.join
patchUse repo.vfs.join instead of repo.join [applied]