pkginfo: only install unittest2 when python version < 2.7 (closes: #76068)

authorSylvain Th?nault <sylvain.thenault@logilab.fr>
changeset8578bf486667
branchstable
phasepublic
hiddenno
parent revision#4a2341d043aa daemon: make pidfile world-readable (closes #75968)
child revision#07acd606dd05 merge
files modified by this revision
__pkginfo__.py
# HG changeset patch
# User Sylvain Thénault <sylvain.thenault@logilab.fr>
# Date 1316101112 -7200
# Thu Sep 15 17:38:32 2011 +0200
# Branch stable
# Node ID 8578bf48666757412b5a0e9022479f8732f3ca7a
# Parent 4a2341d043aafe87edc8a09db430f850ee8bc2a1
pkginfo: only install unittest2 when python version < 2.7 (closes: #76068)

diff --git a/__pkginfo__.py b/__pkginfo__.py
@@ -15,10 +15,11 @@
1  #
2  # You should have received a copy of the GNU Lesser General Public License along
3  # with logilab-common.  If not, see <http://www.gnu.org/licenses/>.
4  """logilab.common packaging information"""
5  __docformat__ = "restructuredtext en"
6 +import sys
7 
8  distname = 'logilab-common'
9  modname = 'common'
10  subpackage_of = 'logilab'
11  subpackage_master = True
@@ -37,6 +38,8 @@
12 
13  from os.path import join
14  scripts = [join('bin', 'pytest')]
15  include_dirs = [join('test', 'data')]
16 
17 -install_requires = ['unittest2 >= 0.5.1']
18 +if sys.version_info < (2, 7):
19 +    install_requires = ['unittest2 >= 0.5.1']
20 +