Pin down dependencies for astroid, for Python 2.6 compatibility.

authorClaudiu Popa <cpopa@cloudbasesolutions.com>
changeset066bfa24a14f
branchpylint-1.3
phasepublic
hiddenno
parent revision#119ec8cb52f3 Added tag pylint-1.3.1 for changeset 6a04e6b44ec8
child revision<not specified>
files modified by this revision
__pkginfo__.py
# HG changeset patch
# User Claudiu Popa <cpopa@cloudbasesolutions.com>
# Date 1423006572 -7200
# Wed Feb 04 01:36:12 2015 +0200
# Branch pylint-1.3
# Node ID 066bfa24a14f59288379638e1d64a9aa856769fd
# Parent 119ec8cb52f3cccec7c1bc6f4f17bf964d0b02a9
Pin down dependencies for astroid, for Python 2.6 compatibility.

diff --git a/__pkginfo__.py b/__pkginfo__.py
@@ -21,14 +21,14 @@
1 
2  numversion = (1, 3, 1)
3  version = '.'.join([str(num) for num in numversion])
4 
5  if sys.version_info < (2, 6):
6 -    install_requires = ['logilab-common >= 0.53.0', 'astroid >= 1.2.1',
7 +    install_requires = ['logilab-common >= 0.53.0', 'astroid <= 1.3.2',
8                          'StringFormat']
9  else:
10 -    install_requires = ['logilab-common >= 0.53.0', 'astroid >= 1.2.1']
11 +    install_requires = ['logilab-common >= 0.53.0', 'astroid <= 1.3.2']
12 
13  license = 'GPL'
14  description = "python code static checker"
15  web = 'http://www.pylint.org'
16  mailinglist = "mailto://code-quality@python.org"