[pkg] prepare 0.63.1

authorDavid Douard <david.douard@logilab.fr>
changeseta83219fcd33d
branchdefault
phasedraft
hiddenyes
parent revision#f468f201d2c1 Fix python3 syntax errors
child revision<not specified>
files modified by this revision
__pkginfo__.py
debian/changelog
debian/control
python-logilab-common.spec
# HG changeset patch
# User David Douard <david.douard@logilab.fr>
# Date 1417172759 -3600
# Fri Nov 28 12:05:59 2014 +0100
# Node ID a83219fcd33d4d51f836848da4b746035ddd587e
# Parent f468f201d2c149fdf0c2e6d3e2a12a9f956d4aa8
[pkg] prepare 0.63.1

diff --git a/__pkginfo__.py b/__pkginfo__.py
@@ -23,11 +23,11 @@
1  distname = 'logilab-common'
2  modname = 'common'
3  subpackage_of = 'logilab'
4  subpackage_master = True
5 
6 -numversion = (0, 63, 0)
7 +numversion = (0, 63, 1)
8  version = '.'.join([str(num) for num in numversion])
9 
10  license = 'LGPL' # 2.1 or later
11  description = "collection of low-level Python packages and modules used by Logilab projects"
12  web = "http://www.logilab.org/project/%s" % distname
@@ -40,10 +40,11 @@
13  scripts = [join('bin', 'pytest')]
14  include_dirs = [join('test', 'data')]
15 
16  install_requires = [
17          'six >= 1.4.0',
18 +	'pytz',
19          ]
20  if sys.version_info < (2, 7):
21      install_requires.append('unittest2 >= 0.5.1')
22  if os.name == 'nt':
23      install_requires.append('colorama')
diff --git a/debian/changelog b/debian/changelog
@@ -1,5 +1,11 @@
24 +logilab-common (0.63.1-1) unstable; urgency=low
25 +
26 +  * new upstream release 
27 +
28 + -- David Douard <david.douard@logilab.fr>  Fri, 28 Nov 2014 11:48:37 +0100
29 +
30  logilab-common (0.63.0-1) unstable; urgency=low
31 
32    * new upstream release
33 
34   -- Julien Cristau <julien.cristau@logilab.fr>  Wed, 05 Nov 2014 14:23:54 +0100
diff --git a/debian/control b/debian/control
@@ -14,10 +14,11 @@
35  Build-Depends-Indep:
36   python-epydoc,
37   graphviz,
38   python-unittest2,
39   python-egenix-mxdatetime,
40 + python-tz,
41   python-six (>= 1.4.0),
42   python3-six (>= 1.4.0) | python3 (<< 3.3),
43  X-Python3-Version: >= 3.3
44  X-Python-Version: >= 2.6
45  Standards-Version: 3.9.1
diff --git a/python-logilab-common.spec b/python-logilab-common.spec
@@ -8,22 +8,22 @@
46  %define __python /usr/bin/python
47  %endif
48  %{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
49 
50  Name:           %{python}-logilab-common
51 -Version:        0.63.0
52 +Version:        0.63.1
53  Release:        logilab.1%{?dist}
54  Summary:        Common libraries for Logilab projects
55 
56  Group:          Development/Libraries
57  License:        LGPLv2.1+
58  URL:            http://www.logilab.org/projects/logilab-common
59  Source0:        http://download.logilab.org/pub/common/logilab-common-%{version}.tar.gz
60  BuildArch:      noarch
61  BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
62 
63 -BuildRequires:  python-devel python-setuptools python-unittest2
64 +BuildRequires:  python-devel python-setuptools python-unittest2 pytz
65  Requires:       mx
66  Requires:       %{python}-six >= 1.4.0
67 
68 
69  %description