Allow rql to work with yapps 2.2.0 which is properly released on pypi, and remove the custom dependency link for it.

Closes #124962 Closes #245540

authorChristophe de Vienne <christophe@unlish.com>
changesetd0892c4e5445
branchstable
phasedraft
hiddenyes
parent revision#4e935a3c321d Added tag rql-debian-version-0.31.5-1 for changeset 2fd17ed747d8
child revision<not specified>
files modified by this revision
__pkginfo__.py
# HG changeset patch
# User Christophe de Vienne <christophe@unlish.com>
# Date 1401913835 -7200
# Wed Jun 04 22:30:35 2014 +0200
# Branch stable
# Node ID d0892c4e54458634cfe923ed41074a4e884d0e5b
# Parent 4e935a3c321db4152a77c01e2a4f795b3b7a9d78
Allow rql to work with yapps 2.2.0 which is properly released on pypi, and remove the custom dependency link for it.

Closes #124962
Closes #245540

diff --git a/__pkginfo__.py b/__pkginfo__.py
@@ -80,13 +80,8 @@
1                      ]
2 
3  install_requires = [
4      'logilab-common >= 0.47.0',
5      'logilab-database >= 1.6.0',
6 -    'yapps == 2.1.1', # XXX to ensure we don't use the broken pypi version
7 +    'yapps ==2.1.1, ==2.2.0', # XXX to ensure we don't use the broken pypi version
8      'logilab-constraint >= 0.5.0', # fallback if the gecode compiled module is missing
9      ]
10 -
11 -# links to download yapps2 package that is not (yet) registered in pypi
12 -dependency_links = [
13 -    "http://download.logilab.org/pub/yapps/yapps2-2.1.1.zip#egg=yapps-2.1.1",
14 -    ]