[pkg] Add python-logilab-constraint to debian dependencies

else we may run into problem when pkg_resources is used, as it will detect that a dependancy in the python package isn't installed.

Fix it this way rather than using extras_require because we want the package to be usable with a simple pip install.

Closes #9343431

authorSylvain Thénault <sylvain.thenault@logilab.fr>
changeset1efe574ab302
branchdefault
phasepublic
hiddenno
parent revision#824af70cc527 Do not set uidrel if RHS of the relation is not a constant.
child revision#3f6fd47874d8 Start test using py.test
files modified by this revision
debian/control
# HG changeset patch
# User Sylvain Thénault <sylvain.thenault@logilab.fr>
# Date 1485531933 -3600
# Fri Jan 27 16:45:33 2017 +0100
# Node ID 1efe574ab3025c1dcfad29b4c718a1bfa54f96f1
# Parent 824af70cc527444d624293d8c02bdc2ad894bda6
[pkg] Add python-logilab-constraint to debian dependencies

else we may run into problem when pkg_resources is used, as it will detect that
a dependancy in the python package isn't installed.

Fix it this way rather than using extras_require because we want the
package to be usable with a simple pip install.

Closes #9343431

diff --git a/debian/control b/debian/control
@@ -26,10 +26,11 @@
1   ${misc:Depends},
2   ${shlibs:Depends},
3   python-logilab-common (>= 0.35.3-1),
4   yapps2-runtime,
5   python-logilab-database (>= 1.6.0),
6 + python-logilab-constraint,
7   python-six (>= 1.4.0),
8  Breaks:
9   cubicweb-common (<< 3.21.99),
10  Suggests: python-pygments
11  Description: relationship query language (RQL) utilities - Python 2
@@ -45,10 +46,11 @@
12   ${misc:Depends},
13   ${shlibs:Depends},
14   python3-logilab-common,
15   python3-yapps2-runtime,
16   python3-logilab-database (>= 1.6.0),
17 + python3-logilab-constraint,
18   python3-six (>= 1.4.0),
19  Suggests: python3-pygments
20  Description: relationship query language (RQL) utilities - Python 3
21   A library providing the base utilities to handle RQL queries,
22   such as a parser, a type inferencer.