[dataio] provide compatibility with CW 3.19 (closes #279602) [applied]