[postgres] remove support for non-psycopg2 drivers [applied]