[shellutils] don't use class decorator, we still need py 2.5 compat for some time. Closes #258060 [applied]