[postgres] Add an adapter for the psycopg2cffi driver, which works great with pypy [applied]