sqlite: drop pysqlite2 support, using plain python sqlite3 module (closes #125083) [applied]